Friday, 26 April 2013

Ubuntu 13.04 Nvidia Optimus Bumblebee

This is how to make Bumblebee works in Ubuntu 13.04 otherwise you will get [ERROR]Cannot access secondary GPU - error: [XORG] (EE) No devices detected.

I have Nvidia GT540M and Intel HD Graphics 3000 on Alienware M11x R3
Open the terminal and follow the instructions below:

1) Add the repository:

sudo add-apt-repository ppa:bumblebee/stable


2) Update the repository index:

sudo apt-get update


3) Install bumblebee:

sudo apt-get install bumblebee bumblebee-nvidia


4) Reboot your system



5) Now we need to get the BusID. Open the terminal again and type:
lspci | grep NVIDIA

It will give you the output:


01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 540M] (rev ff)


01:00.0 is my BusID


6) We need to edit xorg.conf.nvidia. Install GKSU if it is not installed yet.
sudo apt-get install gksu

7) Edit the file:
gksu gksu gedit /etc/bumblebee/xorg.conf.nvidia

8) Go to section device and add the BusID as below:

Section "Device"
    Identifier  "Device1"
    Driver      "nvidia"
    VendorName  "NVIDIA Corporation"
    BusID "PCI:01:00:0"

Take note, it is BusID 01:00:0 instead of dot 01:00.0


9) Restart your system


10) Test to run the bumblebee
optirun glxspheres


Polygons in scene: 62464
Visual ID of window: 0x20
Context is Direct
OpenGL Renderer: GeForce GT 540M/PCIe/SSE2
134.682392 frames/sec - 150.305550 Mpixels/sec
146.435690 frames/sec - 163.422230 Mpixels/sec
145.848772 frames/sec - 162.767230 Mpixels/sec

That's it! It should run perfectly

3 comments:

Unknown said...

Amazing Tutorial. Thank you, that helps me with my new notebook.

Steve said...

Yes! thank you very much.

Steve said...

Any ideas on how to get HDMI working?

I tried this and no luck: http://stephanvaningen.net/wiki/Set_of_commands_to_get_HDMI_working_on_Alienware_M11x

steveman89 [at] gmail.com

Post a comment